Announcement

Collapse
No announcement yet.

Frustratingly slow!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Frustratingly slow!!

    Anyone else having problems with this site? I've been away from the WCI site for a good while and recently have been re-inspired with carving. The problem I'm having is that this forum is so slow that I just quit in frustration. For example, I waited over four minutes just for the "post new thread" function to appear. I thought that it was my PC, but I don't have any problems on any other site but this one. Anyone have any thoughts? Help!!
    Mike

  • #2
    Re: Frustratingly slow!!

    No, I'm not having any speed issues with the site.

    Comment


    • #3
      Re: Frustratingly slow!!

      I am not sure. I have only been on this site for about 5 weeks. It is, however, the slowest site I frequent. Might have something to do with the hacking they experienced.

      Comment


      • #4
        Re: Frustratingly slow!!

        A little slow at times, but nothing like you have experienced, Mike.
        Arthur

        Comment


        • #5
          Re: Frustratingly slow!!

          What browser are you using? I have had zero problems with speed lately. It's been pretty snappy here with Google Chrome.
          Terry

          Comment


          • #6
            Re: Frustratingly slow!!

            Not here lately. Site was acting up a few weeks ago though.
            Carve On,
            Kadiddle

            Comment


            • #7
              Re: Frustratingly slow!!

              I have nno problem with speed but I'm getting very frustrated with the fact that every time I try to post to this site I get a pop-up trying to sell me car insurance.

              Comment


              • #8
                Re: Frustratingly slow!!

                Originally posted by TreeWizard View Post
                I have nno problem with speed but I'm getting very frustrated with the fact that every time I try to post to this site I get a pop-up trying to sell me car insurance.
                I never get that. You might want to check your computer for malware. That's what it sounds like to me.
                Terry

                Comment


                • #9
                  Re: Frustratingly slow!!

                  Thanks Nomad! I switched browsers from Mozilla Firefox to Internet Explorer and it did make a real difference.

                  Mike

                  Comment


                  • #10
                    Re: Frustratingly slow!!

                    I only use Firefox and have no issues.

                    Comment


                    • #11
                      Re: Frustratingly slow!!

                      Originally posted by Steev View Post
                      I only use Firefox and have no issues.
                      My experience also.
                      Arthur

                      Comment


                      • #12
                        Re: Frustratingly slow!!

                        No problems here lately, well computer related anyway. lol

                        Comment

                        Working...
                        X